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1.0 Introduction

Quanta Gold is designed for the professional web designer. There are no WY SIWY G design tools, but
rather tools that allow you to quickly and professionally develop sophisticated web sites. One of the key
features of Quanta is its support of the PHP scripting language (WWw.php.net) as well as HTML, a
CSS editor, and integrated documentation for all of the above. With Quanta you get powerful project
management features for complex web sites with integrated FTP and CVS support. The editor supports
syntax highlighting for HTML, PHP, Javascript and CSS. Other languages will be added in the near
future such as ColdFusion, Python, Perl, etc.

Quanta also supports a variety of HTML preview engines such as Konqueror, Netscape and Mozilla on
Linux and Internet Explorer on Windows. And Quanta doesn't have to be used just for developing
websites. It is a powerful editor with many features that are handy for quick work. The following pages
will describe to you how to use Quanta Gold.



2.0 Installation

When you purchased Quanta Gold you received versions for both Windows and Linux. This chapter will
explain how to install Quanta Gold and its various subsystems.

2.1 How to obtain Quanta Gold

If you're reading this document you should already have Quanta Gold, but if you don't, you can
download a demo or purchase a copy at www.thekompany.com/products/quanta/. When you purchase
Quanta Gold you are entitled to free electronic updates for the life of the product for all supported
platforms, this does not include add-on modules that are available separately.

2.2 Requirements

You will need to be running a 300Mhz or better processor with at least 64MB of RAM, and either a
Linux or MS Windows operating system. For MS Windows we assume Internet Explorer is available for
HTML preview.

Quanta Gold for Linux has been statically linked with all the libraries required, so you don't need to
worry about installing anything else for Quanta Gold - just run it. Quanta Gold has only one Preview
system that is provided with the package - It's Qt3 based HTML rendering engine, but this is a fairly
restricted engine, so we have provided for alternative browser support as well. Quanta Gold uses an X11
Embedding System that allows us to embed a window of a running application inside of Quanta Gold.
This means that you also have the ability to preview with the following:

QT3
Mozilla
Netscape
Konqueror*

* We can't provide you a statically built version of Konqueror because it's included in every version of
KDE, this means you will have to manually compile and install it for your system. We have provided
instructions on how to do that below:

To use Netscape or Mozilla, you will of course have to have them installed. By default Quanta Gold will
search for Netscape as a binary file in : /usr/bin/netscape. If you have installed Netscape in another
palace you can set the full path of the binary file in Option->Preview Dialog.



2.3 Installation

If you are using a Linux system then you need to unpack the Quanta installation package into whatever
directory you like (we recommend /ust/local), by using the tar command:

tar -zxvf quanta-3.2.0-x11.tar.gz

Please note that the version number will change with each release, so the file name may not match the
example. The command creates the directory quanta-3.0 and puts all the files there. Now go into the
directory with the following command:

cd quanta-3.0
Now just run installation script as root:
Jinstall

If you have tried to install as a user other than 'root', then you will receive a warning message. The
installation script will tell you where the files are installed so if you want to remove Quanta Gold from
your Linux system you will only need to remove /usr/local/quanta directory and the symlink /
usr/bin/quanta3.

To install Quanta Gold on a Windows system you need to run the exe installation file. Now just follow
the prompts as you would with any other Windows installer. 1f you select a 'typical’ installation, then not
all features will be installed. If you select a 'full' installation, you can disable features later if you like
with Control Panel->Removing and Add Programs

2.3.1 Installation of Konqueror preview plugin

The “configure' shell script attempts to guess the correct values for various system-dependent variables
used during compilation. It uses those values to create a "Makefile' in each directory of the package. It
may also create one or more ".h' files containing system-dependent definitions. Finally, it creates a shell
script “config.status' that you can run in the future to recreate the current configuration, a file
“config.cache' that saves the results of its tests to speed up reconfiguring, and a file “config.log'
containing compiler output (useful mainly for debugging “configure").

The simplest way to compile this package is:
“cd' to the directory containing the package's source code and type "./configure' to configure the
package for your system. If you're using “csh' on an old version of System V, you might need to
type “sh ./configure' instead to prevent “csh' from trying to execute “configure' itself.

Running “configure' takes a while. While running, it prints some messages telling which
features it is checking for.

Type “make’ to compile the package.
Type “make install’ to install the programs and any data files and documentation. You can

remove the program binaries and object files from the source code directory by typing “make
clean'.



2.4 Starting Quanta Gold

The installation script copies the Quanta binary file to /usr/local/quanta/ and creates a symlink for the
binary: /usr/bin/quanta3 in /usr/bin directory. So to run quanta you just need to type quanta3 on the
command line. If /usr/bin is not in your PATH environment variable you will need to type the full
path+filename - /usr/bin/quanta3

Please remember that to start Quanta Gold you don't need any other systems (except XServer) running on
your Linux system, such as KDE or any other desktop manager. You can use any window manager that

you wish. When activating the Kongueror preview, kdeinit will be activated and some kde daemons and
systems but KDE itself is not running.

If you are using Windows then you need only open Start menu->Programs->Quanta Gold and click on
the shortcut for the application.

If you run quanta3 from a command line then you can add command line attributes. The X11 version of
Quanta Gold knows about -display, -font attributes. For example: quanta3 -display Unix:0 -font
9x15bold. You can also add the name of file to open in quanta: quanta3 myfile.html - then quanta will
start up and load the file into the editor immediately. You can use "open with quanta" in windows by
right-clicking on HTML, php, javascript files.



3. Programs

Quanta Gold uses various external programs to provide specific features rapidly. Specifically we use
Internet Explorer on Windows and for Linux we use Netscape, Mozilla and Konqueror for HTML
preview capability.

We’ve also created a plug in to use the Tidy application for HTML syntax checking and beautifying.

3.1 Preview Systems

The Preview ability is activated by clicking on the preview button at the bottom of the editor window.
Because you can quickly switch between various rendering engines you can test and make sure you
HTML is clean. Remember that the Preview system loads an external program, so their might be some
delay the first time. Sometimes the browser may not embed into Quanta Gold correctly, if this happens
you will see a window without a window manager border on top of all windows. If this happens then
restart Quanta Gold and try it again.

If you receive an error that the preview plug-in cannot be found, please look to see if you have the
program installed on your Linux system, and if you have it set full path of binary file in the Options-
>Previews menu. For example, if you have Netscape installed in /opt/Netscape/ but Quanta Gold tries to
start /usr/bin/Netscape you will see an error. You can create a symlink or open the settings dialog for
preview and set the path there for Netscape binary '/opt/Netscape/netscape’ by using the browse button.

3.2 Syntax Checking

Syntax checking is provided with an external plug in, which is called Tidy. To have Tidy review your
HTML you need to select the Tools->Syntax Check menu item. This will run the Tidy program and
display the results in the message window (you can use Ctrl-M for enabling/disabling the window. By
clicking on items in the message window the cursor will follow lines in the editor and you can quickly
see and fix any errors.

3.3 CVS support

From the Tools->CVS menu you can run various cvs commands for the current file or whole project.
Standard output for these commands will show in the message window. If you are novice with CVS we
recommend that you read some documentation on it. CVS documentation will be included in a later
release.



4. Overview

Quanta Gold has a standard and intuitive style interface with toolbars, menus and tabbed windows for
accessing various sub functions quickly. On the left side of the main window you will see a tabbar that
has various elements, such as: Project, Files, Ftp, Tag, Docs, Struct. The tab bar allows you quick
navigation within the work space. The main window is occupied by the editor. The editor is also
equipped with tab controls along the top that help you to quickly insert various tags or document
construction. On the bottom of the editor you can see a tab with the names of all opened files, this
allows you to easily cut/copy/paste parts of code between these windows. We understand how it is to be
working hard and not want to take your hands off the keyboard, to this end you can use the Alt+Left and
Alt+Right key combinations to navigate between editor windows.

Next to the file name tabs there are three buttons that give you quick access to: Editor B ; Preview 4

; and Documentation window L3 Pop up ToolTips are active pretty much everywhere in the application
that they are needed, and these icons are no different.

Finally, under the editor window and mouse buttons is the Message Panel (which we will explain later).
You can use Ctrl+M to enable/disable the panel if you want to get some more screen real estate, or if you
need it open because you are debugging.

4.1 Dock windows

Quanta Gold makes heave use of 'Dock Windows', this allows you to essentially tear off any visible
toolbar or panel and position it wherever you want on the screen, either internal or external to the
program, docked or free floating. This allows you to customize your work environment so it is
comfortable and natural for the way you work.






4.2 Main window

In this screenshot you will see the bottom of the editor window that shows the aforementioned buttons,

and a tag for the single document in this editor called ‘overview.html'. If there was more than one tab,

you could click to quickly switch between editor panes.

4.3 File views

Quanta Gold has two File views. They are located on the panel named Files. The first is a list style
interface, you can open a directory or select a file by single clicking on it. Here is an example:
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By right clicking you can switch to "tree mode", which is the second interface, to do
copy,paste,delete; insert file or directory in current project and reload current dir if there are new

elements.




Our next file style is "Tree Mode', this is

where you can expand or collapse directory structures by

clicking on the icon next to the name, or double clicking on the name. While this is useful for certain
types of operations, it can create a cluttered view as well. See the example below:
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You can switch back to 'list mode' just right clicking and selecting it from the pop up menu.



4.4 Project window

The Project Panel is for managing you project and the files within it. If no project exists, then the root
folder name will say “No project”. If you double click on that name, you will get the “Project Open
Dialog”. This is a nice shortcut to using the menu bar.

| |

Right clicking in the Project panel will allow you to add, delete, create and open files as well as perform
various CV'S operations. Please note that Quanta Gold can open projects created with Quanta Plus, but
won't go the other way. The file format for Quanta Plus was not very efficient with large numbers of
files, so Quanta Gold is a better option.



4.5 Ftp browser

At first glance the FTP client appears to be very basic. There is a window with a list of connections, if
you look at the example below you can see that multiple connections can be maintained. There are
options to modify all of the attributes of an FTP server, such as the connection name, ip address or
hostname, the port number (this is especially handy with Zope for example which uses a port other than
21, which is the default). Final the "Path" - string that contains the path of a directory on a remote server

and user/password attributes.
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When you click on the connect button, the "Ftp browser" will change its looks and will have two panels:
The top panel with the filesystem of the remote server and panel with your local files.

The next elements are:

Remote->(New directory;Remove selected;Reload)
Local->(New directory;Remove selected;Reload;Change dir)
Compare->(By date;By size)

Download and Upload buttons

"Disconnect"
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Note that panels have a "filemanager-like" selection mode. You can single click on a file and shift or ctrl
click on other files to select a group of files or directories. “Compare™ allows you to compare your files
with files on a server. If you have project that contains a large number of files and you don't remember
which files you changed on your local computer or maybe someone else changed them, then function
"Compare by Date" or "Compare by Size" can be very useful.



4.5 Documentation Panel

The Documentation Panel provides you ready access to various documents to help you in with your web
programming. We have integrated the HTML 4.0 manual, Cascading Style Sheets documentation,
JavaScript 1.3, PHP 4.0, MySQL and PostgreSQL. The panel has a tree-like structure where you can
select the theme that you are interesting in, select sub-points and read the page in the Documentation
Window, where Quanta Gold switches to when you click on an element in the panel. Basically select a
theme, click on it and you get the documentation page, from there you can follow through links to other
documentation. Here is an example:
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4.6 Context help

Quanta Gold has a very friendly integrated help system, simply set the cursor on the word you are
interested in and press F1 on your keyboard. The documentation window will now appear with help
information regarding the selected word. For example entering the word "body" and pressing the F1
button will open a manual page about the attributes of the tag and its description.



4.7 Structure Panel

The Structure Panel is used to examine the structure of the page you are currently editing and make sure
that it is correct. If your HTML has a structure error, then looking at the structure panel will display that
the structure tree is closed after the offending tag. This will indicate that you have a problem that
disallows the continued parsing of the document. Some browsers try to understand structural errors, but
often times no error will display, but Quanta will glaringly display the problem. It's important that you
check for structural errors as not all browsers will understand them.

Using the mouse in the panel you can follow text with the cursor and see how your typing changes the
structure of the document and fix it on the fly in the control structure. At the top of the tree you will see
two “folders” that contain all the links and images in the document. By double clicking on an element
with the link or image, you will have selected the tag for that element in the editor window. By single
clicking on the element you will have the cursor jump to the beginning of the tag in the editor window.
This is very handy for rapid navigation of your document.

When you click on any element in the structure tree your cursor will jump to the beginning of the
text/tag. By double clicking that area will be highlighted. You can access this feature by right clicking
and selecting 'Select Tag Area' or 'End of Tag'. With complex HTML and tables, using the 'End of Tag'
option can be very useful to quickly find the right end tag. The 'Open' and 'Close’ options act the same as
clicking on the plus/minus in the tree. 'Reparse’ will update the tree of the current document. See the
following screenshot for a sample:
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4.8 Tag Attributes Panel

The Tag Attributes Panel is very helpful, basically it takes the tag of where your cursor is currently
located and displays a list of properties and values for that tag. Simple click on an attribute and change
its value. All your values are inserted on the fly, this is like using a RAD development tool such as
Visual Basic or Delphi. Check out this example:
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4.9 Messages Panel

The Message Panel is a basic output window where the various programs and functions of Quanta Gold
will output their messages. If the line in the message panel contains a line number, then you can
highlight the line you are interested in, click on it, and the appropriate window will come up with the
appropriate text.

Currently Quanta Gold only supports output from Tidy, which makes it very handy for debugging your
HTML code.

&
Tidy (vers 4th August 2000) Parsing console input (stdin) J
line 9 column 1 - Warning: inserting nissing 'title’ element
line 38 column 26 - Warning: <imgy lacks “alt" attribute
ling 39 column 10 - Warning: <imgy lacks "alt' attribute
line 40 column 2 - Varning: <imgy lacks "alt' attribute
line 50 column 35 - Warning: missing </ay before <hdy
ling 50 column 56 - Warning: discarding unegpected </a) j




4.10 Configure Toolbar Items

You probably are wondering how you can add your own tags or scripts or something else to even further
customize Quanta, well we thought about that to, so we added the Tags Bar options. In this dialog you
can add, modify, delete, change order, or save to an external file. To access the menu, right click on the
Tags Bar, or select "Options->Configure actions”. Here is a screenshot with the default Quanta Gold
actions configuration :

Bodule Info

In the left panel you can see a structure will all available actions. You can change the order, or create
sub-trees by simply dragging and dropping elements. For example, if you want to have access to a font
element from the "Standard" tab you can click on the "Font" folder, then drag and drop it in the
"Standard" folder as a sub menu - try it and you will see how easy it is.






On the bottom you can see buttons that will perform various operations such as "New
action/tabbat/sublist”, "Open from file", "Save" and "Delete”. On the left side is the part for configuring
the current action: "Text", "ToolTip", "Status text" "Hot key". Note that the hot key format is "Alt+i". In
the next version of Quanta we will implement a special widget for hotkey configuration.

Now lets look at some examples. Text - this is text that will be in the tag bar if you don't set an icon for
the action. Below that are confirmation options of the action on the element. The next elements are:
"Tag", "Script", "Text", "Others". "Others" is created for non standard elements like "Quick start dialog"
and is hard coded into Quanta Gold, so this element won't be very useful for you, but it is need for

compatibility.

"Tag" allow you define your own tags, "Run edit dialog if available” allows you to create your own
dialogs for your tags. Documentation about writing your own tag files was created by Richard Moore
and with it you can easily define your own dialogs that will be run when you press the “F4” function key
or when inserting the tag from tagsbar.

"Text" tab allow you to define multiline text on an action - there are two parts of text - before cursor and
after. Now look at the next element "Script" tab. This is a powerful function that allows you to create an
interface from Quanta Gold to an external script or program. First - you select the program that will be
run on the action. Below you define connections with the program: "Input” - this is text that will be sent
to standard input of the program, "Output" - is actions that you need to do with output of the program
after it runs.

Your next options are: "Insert in current position”, "New document”, "Replace current document™ and
"Message window". Same rules on error output (stderr). With the powerful configurable dialog you can
create your own dialogs/wizards (with Tcl/Tk for example), do spell checking of your documents and
almost any other thing that you don't have in Quanta Gold at the moment.

If you have created your own collection of Scripts/Tags or others elements that you think other people

will find useful or interesting, you can send them to 'info@thekompany.com' and we'll see about
adding them to the product.




4.11 Keyboard shortcuts

Quanta Gold provides keyboard shortcuts for almost all the available actions in the application.

F1 — popup help for the word/tag that the cursor is on.

F3 - find next action.

F4 - edit current tag - raise dialog with attributes of current tag.

F5 - reload current preview when you are in Preview mode

F6 - enable/disable preview window. Take note that Quanta Gold can use an external applications for
previewing as described earlier. Quanta Gold hot keys will not work while the external program has the
keyboard focus, you must bring the focus back to Quanta and then press F6 again ito close the preview.
This is a function of X11 embedding and is not a bug in Quanta Gold.

Ctrl-M - Show Message window. Alt - Enter to menu bar.

File operations:

Ctrl-N - New file.

Ctrl-O - Open file.

Ctrl-W - Close file.

Ctrl-S - Save file.

Ctrl-Q - Quit from Quanta Gold.

Editor operations:

Ctrl-Z - Undo.

Ctrl-Shift-Z - Redo.

Ctrl-X - Cut.

Ctrl-C - Copy.

Ctrl-V - Paste.

Ctrl-A - Select All.

Ctrl-1 - Indent.

Ctrl-U - Unindent.
Ctrl-Space - Complete word.
Alt-Left, Alt-Right - switch to prev,next editor window.

Search operations:
Ctrl-F - Search.
F3 - Search next.
Ctrl-R - Replace.
Ctrl-J - Goto Line.

Tags operations:

Alt-Enter - Enter <br> tag
Alt-Space - Enter &nbsp; entity
Alt-1 - Img tag dialog.



5. Projects support

Project support in Quanta Gold allows you to organize your web-development in a logical structure you
can easily work with. Quanta Gold works with your projects based on the file extension, you can use .
wpj, .webprj or .webproject, whatever is comfortable. The files in a project are organized in a tree-like
structure that mirror the directories and file structure on your disk. You can perform operations against
the entire project such as scanning files and directories, CVS operations and such.

5.1 Create new project

Creating new project is quite simple. By selecting the menu item "Project->New Workspace" you will
see a dialog for setting the project directory, project filename , and project name which contains some
information for you. So enter in the "Project Name" a short description or name of your project. In
"Project Directory" you must select the directory where the files for your project will be. If the directory
does not exists you can write the full directory filename in the lineedit then the directory will be created.
Also you can use the "Create New Folder"” button in "Open dialog" which you can run by clicking on the
button "...". In lineedit "Project File Name" you must enter the file name of a project file. The file name
must have the extension ".wpj" ".webprj" or ".webproject". For example — my_project.wpj. Once you've
done this, click on “OK” and your project will then be opened in the Project Panel where you can start

adding files.

5.2 Export Quanta Plus 2.0 project

You can open project files in Quanta Plus 2.0 (also known as Quanta Plus) format but you can only save
in the Quanta Gold file format. This is because the file format in Quanta Plus wasn't very efficient.
Saving or opening projects with thousands of files in then was painfully slow, this has been fixed with
the new Quanta Gold file format.

5.3 Adding new files to project

To add files to a project, you can right click on the projects folder in the Project Panel and select “Add
files to folders”. This will open up a dialog that allows you to select what files you want to add. If you
select a different directory for the files to include, then they will be copied into your work directory.

You can create a new folder inside a project by selecting the 'New Folder' option. Simply enter the
folder name and click on 'Ok’. This will create the directory on your disk at the same time. The next
feature is available from the menu “Project->Add new files” (note that the option “Project->Add existing
file...” is the same as the right click in the project tree).

When you add a new file, Quanta Gold will prompt you with a 'save file' dialog so it knows where to put
the new file and what to call it. A powerful companion feature is the menu item 'Project->Scan for new
files'. When you select this you will get a checkable tree like file/directory structure which is not
included in the current project. From here you can easily select missing files. See the screenshot below.

In the dialog on top you can select the project's folder which you want to check for existing new files.
Below you can enter a mask for files that you want to exclude. In the tree you can select files for addition
by clicking once on files that you are interesting in. When you click on the checkbox you will have all
files and subdirectories with files selected for addition. When you clear the checkbox on the folder you
will clear all selections inside. So this feature allows you to very quickly navigate a project directory for
new files and select them for addition.
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5.4.1 CVS support

Quanta Gold also has very basic CVS support which will continued to be enhanced in the future. Now
you can update or commit changes of the entire project directory by selecting "Tools->CVS-
>Update/Commit Project"”. This feature will save changes in your files and run "cvs" command. T he
command will output all messages in the "Message window" and there you can see which files were
modified or which files are updated from other developers. You can also update/commit for one file by
selecting "Tools->CVS->Update/Commit" or use "Project Panel" by right mouse clicking. Note that
using cvs commands for a folder will updates all files and directories recursively inside the folder.



6. CVS integration

As previously mentioned, basic CVS support has been added to Quanta Gold. Soon we will be adding
features such as log browsing, merging and resolving conflicts among other features.

6.1 Requirements

You must have CVS installed on your Linux system to use it, on Windows you need to select “CVS
support™ in the installation wizard. For working with CVS in Quanta Gold on a project you need to have
the project uploaded by using the "cvs checkout" command from a console. After that you will have a
project with directories CVS inside folders. Once you have done this, then CVS operations will be
available in Quanta Gold.

CVS documentation will be added to the Quanta Gold help system to keep it consistent with the other
integrated sub-systems.

There have been a number of requests for us to host CVS projects for Quanta Gold. We are considering
making this an option in the future.

6.2 Using

Quanta Gold also has very basic CVS support which will continued to be enhanced in the future. Now
you can update or commit changes of the entire project directory by selecting "Tools->CVS-
>Update/Commit Project”. This feature will save changes in your files and run "cvs" command. T he
command will output all messages in the "Message window" and there you can see which files were
modified or which files are updated from other developers. You can also update/commit for one file by
selecting "Tools->CVS->Update/Commit" or use "Project Panel" by right mouse clicking. Note that
using cvs commands for a folder will updates all files and directories recursively inside the folder.



7. Editor

The Editor that is used in Quanta Gold is another product developed at theKompany by Max Judin and is
used in a variety of our products. The editor has standard features for editing, powerful highlighting
system which allow you easily navigate in your code, on the fly checking and repair of errors. A
powerful and unique feature is the ability to syntax highlight different languages with different colors at
the same time, so when you have a page that is integrated HTML+PHP or PHP+HTML+JAVASCRIPT
you can easily distinguish what you are looking for. HTML tag editing can be accomplished by pressing
F4. Word completion has also been implemented for speeding up your work even more.

7.1 Options

By selecting the menu item "Options->Fonts" you can modify the font used in the editor window. A
monospace font is really more useful for editing, but you can select any font available in the 'font dialog'.

By selecting the menu item "Options->Editor" you can choose your own settings to control the behavior
of the editor. Other options available are:

Auto indent — Allows you to save the indentation used in the previous line.

Backspace Indent — Remove indent by pressing backspace.

Smart Home - With this feature when you press the "Home" button the cursor jumps to the first non-
space symbol in the line and then with the second pressing the cursor jumps to the beginning of the line.
Wrap cursor — If you have a long line, the text will automatically go to the next line.

Replace tabs — Sometimes it is better to uses an actual space instead of a tab to indent code, this option
will go through and replace the tabs with a specified number of spaces.

Remove Trailing Spacers — This will eliminate embedded spaces at the end of the document.

Margins:

Indicator Margin — Not currently used, but a future release will be used to indicate code folding,
bookmarks and more.

Line Number Margin — The line numbers can be turned off, but frequently having the line numbers is
useful with PHP development when you are receiving messages for errors. You will also need them
when doing a syntax check in Quanta Gold

Selection Margin — Allows you to select a range or area more flexibly than would otherwise be possible.

7.2 Word completion

Word completion can be a big time saver when working on extensive document. It is very simple to use,
while typing just press Ctrl+Space and you receive a popup menu that contains all word that you already
have entered in the text that match the symbols currently entered. Just select what you want and press
‘Enter".

7.3 Tag editing

Tag Editing is a powerful tool for entering or changing the attributes of the current tag. Just put the
cursor between the <tag> and </tag> (not actually in a tag, but between them) and press F4. Quanta
Gold will parse all the attributes of the current tag and load in a dialog that will allow you to modify any
value, then just press 'Ok" and you will switch back to the editor window. Quanta Gold now also
supports HTML 4.0 tag dialogs.






8. Questions and answers

This section will build over time as your questions come in, for now there is nothing to comment on.

8.1 Known bugs and bugs reporting

You can report bugs directly to the developers if you wish at the following addresses:

Alexander Yakovlev <yshurik@thekompany.com>
Dmitry Poplavsky <dima@thekompany.com>

Bugs take priority over features and we will address them as quickly as possible.

8.2 Quanta Gold mailing list

We have a mail list for Quanta Gold customers set up. If you purchased from our web site you would
have received information on it already, if you purchased from another source then you will need to
register your product so that you can join the mail list. The mail list is called qg@thekompany.com

8.3 Where to find more information

Our web site has product information available as well if this document doesn't answer your questions.
Please see Www.thekompany.com/products/quanta. You can also send an email to
info@thekompany.com.

8.4 How to buy Quanta Gold

Quanta Gold is available from many online and brick and mortar retailers, but it can also be purchased
directly from our website at www.thekompany.com/products/quanta.
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10. Copyright

CONTRACT between you (either an individual or a single entity) and TheKompany.com Inc.
(theKompany.com), which covers your use of either "Quanta Gold" and related software components.
All such software is referred to herein as the "Software Product.” A software license and a license key or
serial number ("Software Product License"), issued to a designated user only by TheKompany.com Inc.
or its authorized agents, is required for each concurrent user of the Software Product. If you do not agree
to the terms of this EULA, then do not install or use the Software Product or the Software Product
License. By explicitly accepting this EULA you are acknowledging and agreeing to be bound by the
following terms:

1. EVALUATION LICENSE WARNING (can probably drop this whole paragraph)

This Software Product can be used in conjunction with a free evaluation Software Product License. If
you are using such an evaluation Software Product License, you may use the Software Product only to
evaluate its suitability for purchase. Evaluation Software has been limited in some way either through
timeouts, disabled save or restricted use. TheKompany.com Inc. BEARS NO LIABILITY FOR ANY
DAMAGES RESULTING FROM USE (OR ATTEMPTED USE AFTER EXPIRATION) OF THE
SOFTWARE PRODUCT, AND HAS NO DUTY TO PROVIDE ANY SUPPORT BEFORE OR
AFTER THE EXPIRATION DATE OF AN EVALUATION LICENSE.

2. GRANT OF NON-EXCLUSIVE LICENSE

TheKompany.com Inc. grants the non-exclusive, non-transferable right for a single user to use this
Software Product. Each additional concurrent user of the Software Product requires an additional
Software Product License. In the case that the source code is provided with the Software Product,
theKompany grants you the right to modify, alter, improve, or enhance the Software Product without
limitation, except as described in this EULA. Although rights to modification of the Software Product are
granted by this EULA, you may not tamper with, alter, or use the Software Product in a way that
disables, circumvents, or otherwise defeats its built-in licensing verification and enforcement capabilities.
The right to modification of the Software Product also does not include the right to remove or alter any
trademark, logo, copyright or other proprietary notice, legend, symbol or label in the Software Product.
Any modifications made to the Software Product will render it non-supportable by TheKompany.com.
You may at your discretion submit changes back to TheKompany.com and if they are incorporated into
the Software Product then the changes will become supported by TheKompany.com. and ownership of
the patch is transfered to The Kompany.com Inc. You may not distribute or redistribute changes made to
the Software Product to anyone other than TheKompany.com Inc. Although the source code for the
Software Product is included you may not share, use, reuse the knowledge or technologies in other
applications without explicit approval from TheKompany.com Inc. You may make copies of the
Software Product as reasonably necessary for its use. Each copy must reproduce all copyright and other
proprietary rights notices on or in the Software Product. You may install each Software Product License
on a single computer system. A second installation of the same Software Product License may be made
on one other computer system, so long as both copies of the same Software Product License never come
into concurrent use. You may also make copies of the Software Product License as necessary for backup
and/or archival purposes. Backup and archival copies may not come into active use, together with the
Software Product, for any purpose. No other copies may be made. Each copy must reproduce all
copyright and other proprietary rights notices on or in the Software Product License. You may not
modify or create derivative copies of the Software Product License. All rights not expressly granted to
you are retained by TheKompany.com Inc.

3. INTELLECTUAL PROPERTY RIGHTS RESERVED BY THE KOMPANY.COM INC.

The Software Product is owned by theKompany and is protected by United States and international
copyright laws and treaties, as well as other intellectual property laws and treaties. You must not remove
or alter any copyright notices on any copies of the Software Product. This Software Product copy is
licensed, not sold. You may not use, copy, or distribute the Software Product, except as granted by this
EULA, without written authorization from TheKompany.com Inc. or its designated agents. Furthermore,
this EULA does not grant you any rights in connection with any trademarks or service marks of
TheKompany.com Inc. theKompany reserves all intellectual property rights, including copyrights, and
trademark rights.



4.NO RIGHT TO TRANSFER

You may not rent, lease, lend, or in any way distribute or transfer any rights in this EULA or the
Software Product to third parties without The Kompany.com Inc.'s written approval, and subject to
written agreement by the recipient of the terms of this EULA.

5. INDEMNIFICATION

You hereby agree to indemnify TheKompany.com Inc. against and hold harmless TheKompany.com Inc.
from any claims, lawsuits or other losses that arise out of your breach of any provision of this EULA.

6. THIRD PARTY RIGHTS

Any software provided along with the Software Product that is associated with a separate license
agreement is licensed to you under the terms of that license agreement. This license does not apply to
those portions of the Software Product. Copies of these third party licenses are included in all copies of
the Software Product.

7. SUPPORT SERVICES

TheKompany.com Inc. may provide you with support services related to the Software Product. Use of
any such support services is governed by The Kompany.com Inc. policies and programs described in
online documentation and/or other TheKompany.com Inc.-provided materials. As part of these support
services, TheKompany.com Inc. may make available bug lists, planned feature lists, and other
supplemental informational materials. TheKompany.com Inc. MAKES NO WARRANTY OF ANY
KIND FOR THESE MATERIALS AND ASSUMES NO LIABILITY WHATSOEVER FOR
DAMAGES RESULTING FROM ANY USE OF THESE MATERIALS. FURTHERMORE, YOU
MAY NOT USE ANY MATERIALS PROVIDED IN THIS WAY TO SUPPORT ANY CLAIM MADE
AGAINST TheKompany.com Inc.. Any supplemental software code or related materials that
TheKompany.com Inc. provides to you as part of the support services, in periodic updates to the
Software Product or otherwise, is to be considered part of the Software Product and is subject to the
terms and conditions of this EULA. With respect to any technical information you provide to
TheKompany.com Inc. as part of the support services, TheKompany.com Inc. may use such information
for its business purposes without restriction, including for product support and development.
TheKompany.com Inc. will not use such technical information in a form that personally identifies you
without first obtaining your permission.

8. TERMINATION WITHOUT PREJUDICE TO ANY OTHER RIGHTS

TheKompany.com Inc. may terminate this EULA if you fail to comply with any term or condition of this
EULA. In such event, you must destroy all copies of the Software Product and Software Product
Licenses.

9. U.S. GOVERNMENT USE

If the Software Product is licensed under a U.S. Government contract, you acknowledge that the software
and related documentation are "commercial items," as defined in 48 C.F.R 2.01, consisting of
"commercial computer software" and "commercial computer software documentation,™ as such terms are
used in 48 C.F.R. 12.212 and 48 C.F.R. 227.7202-1. You also acknowledge that the software is
"commercial computer software" as defined in 48 C.F.R. 252.227-7014(a)(1). U.S. Government agencies
and entities and others acquiring under a U.S. Government contract shall have only those rights, and shall
be subject to all restrictions, set forth in this EULA. Contractor/manufacturer is TheKompany.com Inc.,
P.O. Box 80265, Rancho Santa Margarita CA 92688, USA.

10. EXPORT RESTRICTIONS

You will not download, export, or re-export the Software Product, any part thereof, or any software, tool,
process, or service that is the direct product of the Software Product, to any country, person, or entity --
even to foreign units of your own company -- if such a transfer is in violation of U.S. export restrictions.
11. NO WARRANTIES

YOU ACCEPT THE SOFTWARE PRODUCT AND SOFTWARE PRODUCT LICENSE "AS IS,"
AND THEKOMPANY AND ITS THIRD PARTY SUPPLIERS AND LICENSORS MAKE NO
WARRANTY AS TO ITS USE, PERFORMANCE, OR OTHERWISE. TO THE MAXIMUM EXTENT
PERMITTED BY APPLICABLE LAW, THEKOMPANY AND ITS THIRD PARTY SUPPLIERS
AND LICENSORS DISCLAIM ALL OTHER REPRESENTATIONS, WARRANTIES, AND
CONDITIONS, EXPRESS, IMPLIED, STATUTORY, OR OTHERWISE, INCLUDING, BUT NOT
LIMITED TO, IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY,
SATISFACTORY QUALITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-
INFRINGEMENT. THE ENTIRE RISK ARISING OUT OF USE OR PERFORMANCE OF THE



SOFTWARE PRODUCT REMAINS WITH YOU.

12. LIMITATION OF LIABILITY

THIS LIMITATION OF LIABILITY IS TO THE MAXIMUM EXTENT PERMITTED BY
APPLICABLE LAW. IN NO EVENT SHALL THEKOMPANY OR ITS THIRD PARTY SUPPLIERS
AND LICENSORS BE LIABLE FOR ANY COSTS OF SUBSTITUTE PRODUCTS OR SERVICES,
OR FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES
WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS
PROFITS, BUSINESS INTERRUPTION, OR LOSS OF BUSINESS INFORMATION) ARISING OUT
OF THIS EULA OR THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT OR THE
FAILURE TO PROVIDE SUPPORT SERVICES, EVEN IF THEKOMPANY HAS BEEN ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES. IN ANY CASE, THEKOMPANY'S, AND ITS THIRD
PARTY SUPPLIERS' AND LICENSORS', ENTIRE LIABILITY ARISING OUT OF THIS EULA
SHALL BE LIMITED TO THE LESSER OF THE AMOUNT ACTUALLY PAID BY YOU FOR THE
SOFTWARE PRODUCT OR THE PRODUCT LIST PRICE; PROVIDED, HOWEVER, THAT IF
YOU HAVE ENTERED INTO AN THEKOMPANY SUPPORT SERVICES AGREEMENT,
THEKOMPANY'S ENTIRE LIABILITY REGARDING SUPPORT SERVICES SHALL BE
GOVERNED BY THE TERMS OF THAT AGREEMENT.

13. HIGH RISK ACTIVITIES

The Software Product is not fault-tolerant and is not designed, manufactured or intended for use or resale
as on-line control equipment in hazardous environments requiring fail-safe performance, such as in the
operation of nuclear facilities, aircraft navigation or communication systems, air traffic control, direct life
support machines, or weapons systems, in which the failure of the Software Product, or any software,
tool, process, or service that was developed using the Software Product, could lead directly to death,
personal injury, or severe physical or environmental damage ("High Risk Activities™). Accordingly, The
Kompany.com Inc. and its suppliers and licensors specifically disclaim any express or implied warranty
of fitness for High Risk Activities. You agree that TheKompany.com Inc. and its suppliers and licensors
will not be liable for any claims or damages arising from the use of the Software Product, or any
software, tool, process, or service that was developed using the Software Product, in such applications.
14. GOVERNING LAW; ENTIRE AGREEMENT ; DISPUTE RESOLUTION

This EULA is governed by the laws of the Commonwealth of Massachusetts, U.S.A., excluding the
application of any conflict of law rules. The United Nations Convention on Contracts for the
International Sale of Goods shall not apply. This EULA is the entire agreement between
TheKompany.com Inc. and you, and supersedes any other communications or advertising with respect to
the Software Product; this EULA may be modified only by written agreement signed by authorized
representatives of you and TheKompany.com Inc.. Unless otherwise agreed in writing, all disputes
relating to this EULA (excepting any dispute relating to intellectual property rights) shall be subject to
final and binding arbitration in the State of California, in accordance with the Licensing Agreement
Avrbitration Rules of the American Arbitration Association, with the losing party paying all costs of
arbitration. Arbitration must be by a member of the American Arbitration Association. If any dispute
arises under this EULA, the prevailing party shall be reimbursed by the other party for any and all legal
fees and costs associated therewith.

15. GENERAL

If any provision of this EULA is held invalid, the remainder of this EULA shall continue in full force and
effect. A waiver by either party of any term or condition of this EULA or any breach thereof, in any one
instance, shall not waive such term or condition or any subsequent breach thereof.

16. OUTSIDE THE U.S.

If you are located outside the U.S., then the provisions of this Section shall apply. The parties confirm
that this EULA and all related documentation is and will be in the English language. You are responsible
for complying with any local laws in your jurisdiction which might impact your right to import, export or
use the Software Product, and you represent that you have complied with any regulations or registration
procedures required by applicable law to make this license enforceable.

17. TRADEMARKS

The following are trademarks or registered trademarks of TheKompany.com Inc.: theKompany, Kivio,
BlackAdder, KDE Studio Gold, Quanta Gold, DocBrowser, Aethera, Kode, and Rekall.

18. CONTACT INFORMATION

If you have any questions about this EULA, or if you want to contact The Kompany.com Inc. for any



reason, please direct all correspondence to: theKompany P.O. Box 80265, Rancho Santa Margarita, CA
92688, United States of America or send email to info@thekompany.com.



