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           dbRadar is a tool for the administration, monitoring and development of a variety of Databases. 
It is available for Linux and Windows (Mac OS X coming soon). dbRadar competes very favorably 
with products such as TOAD from Quest Software and NORAD from Bradmark, but at a fraction of the 
price. dbRadar works with the following databases: · Oracle · PostgreSql · MySql · DB2. 

          See more on features ... 
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Features

●     Features 
●     Planned features 

            dbRadar is a tool for the administration, monitoring and development of a variety of Databases. 
It is available for Linux and Windows (Mac OS X coming soon). dbRadar competes very favorably with 
products such as TOAD from Quest Software and NORAD from Bradmark, but at a fraction of the 
price. 
             dbRadar works with the following databases: 

●     Oracle 
●     PostgreSql 
●     MySql 
●     DB2 
●     ODBC ( only for Windows ) 

            If the connection is successful the worksheet will open and the user can then use any DDL and 
DML that the target database supports. dbRadar uses the MDI approach for representing all of its child 
windows. This means that the user can open as many windows as he/she wants, close and navigate 
through them. From the File menu the user can Print, Save and Load any text files into the worksheet 
and execute them as sql scripts. The user can drop the actual connection with the database and start a 
new one from the File menu. 
            In the worksheet the user can cut, copy and paste any text using the appropriate key (CTRL-X, 
CTRL-C, CTRL-V) combination or by choosing the edit menu after the text has selected. The Database 
menu offers the user ability to open a new worksheet or a new system load window. To switch from one 
window to another, use the Window menu. For Oracle and PostgreSql connections the user has the 
ability to use code completion for selecting columns from the tables. The user can save the result set by 
right clicking the mouse over the grid and choosing a name for the file. 
            For Oracle connections only, the user can browse the objects from the database using the tree 
representation from the left and also can choose to see the execution path for a specific select statement 
by clicking the explain button from the worksheet toolbar. 

Features

●     Worksheet - Issue any DDL or DML that is supported by the target database. The result set is 
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presented in a grid from which it can also be saved. A status display will indicate the progress of 
the query. 

●     Threaded Queries - Queries run in their own thread so that the application remains responsive 
even during long executions. A special feature for Oracle databases is the ability to break any 
long running query. 

●     Multiple, simultaneous database connections. The user can switch from one connection to 
another. 

●     Powerfull editor with Syntax highlighting for : SQL, PL/SQL, PGPL/SQL, MYSQL, DB2 
●     Code completion - Makes it quick and easy to select columns you want from your particular 

database. This feature is only available for Oracle and PostgreSQL currently. 
●     Oracle Applications - Only for Oracle Business Suite 11.0.3 and 11.5. You can monitor OA users 

and kill sessions. An upcoming version will allow you to view concurrent requests. 
●     Remote Info - Gather remote/local HP-UX and Linux load (system, user, idle) and processes. 
●     Database Objects - Users can visually browse and edit database objects (Oracle only). 
●     Save/Load any text files and execute them as SQL scripts. 
●     Print any text in a worksheet. 
●     Tuning - The worksheet provides a tabbed page where the user can see the execution path for the 

current statement executed in a tree fashion (only for Oracle currently) 
●     Supports statements with placeholders in the worksheet. This way a user can insert something 

like a large object into the database. 

Planned Features

●     FTP integration in a project. 
●     Windows remote load shown in graphically. 
●     Users can visually browse and edit database objects for Postgres, Mysql and DB2. 
●     Support for Sql Server, Sybase, Sap, Interbase, Firebird, SqlLite 
●     Show online database performance indicators (buffer cache hits, library cache hits - for Oracle 

databases) 
●     By making use of our multiple database connections we will also be able to migrate data from 

one database to another. 
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Connect to Databases

            When dbRadar starts the connect screen will appear: 

            Oracle client libraries 8i/9i and DB2 client libraries need to be installed to have access to those 
databases. Choose the connection you want from the driver combo box and fill the text boxes with the 
appropriate information. Ex for Oracle connections: 
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●     Driver - the driver that creates the connection 

●     Database Name - the name of the database we want to connect(for Oracle - connect string) 
●     Username - the user who will make the connection 
●     Password - the password for the user 
●     Connection Mode - (only for Oracle) :Normal, Sys_Dba, Sys_Oper 
●     Hostname - the name or IP address of database server we want to connect to. (Not needed for 

Oracle). Based on this address we can monitor the remote server 
●     Port - the port for the server database. Use this port if the database process is running on other 

port than the default one. 
●     Oracle Applications - if the Oracle database is running Oracle Applications 11.0 or 11.5 the 

sysdba can monitor users and kill sessions. An upcoming version will allow you to view 
concurrent requests. 

●     Unix login - asks you for the username and password of a valid user that has shell access on the 
server. This way you can monitor the load of the server and all running processes. The remote 
server needs to be Linux or HP-UX and have rexecd (512 port) daemon process running so you 
can have access to those informations. The connections are logged so when you connect next 
time you don't have to fill in all the information for the connection. Just choose the appropriate 
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one from the list of connections: 

            If the connection is successful the worksheet is open and the user can use any DDL and DML 
that the target database supports. dbRadar uses the MDI approach for representing all of its child 
windows. 
            This means that the user can open as many windows as he wants, close and navigate through 
them. From the File menu the user can Print, Save and Load any text files into the worksheet and 
execute them as SQL scripts. The user can drop the actual connection with the database and start a new 
one from the File menu. In the worksheet the user can cut, copy and paste any text using the appropriate 
key (CTRL-X, CTRL-C, CTRL-V) combination or by choosing the edit menu after the text has selected. 
The Database menu offers the user the ability to open a new worksheet or a new system load window. 
To switch from one window to another use the Window menu. 

Home
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Worksheet

●     Sintax Highlight 
●     Code Completion 
●     Explain Plan 
●     Placeholders 

Sintax Highlight

             In the worksheet the user can Issue any DDL or DML that the target database suports. For 
Oracle PL/SQL code users can nagivate throught the lines witch have errors. Having suport for Syntax 
highlighting makes programming more intuitive. 
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Code Completion

             For Oracle and PostgreSql connections the user has the ability to use code completion for 
selecting columns from the tables. The user can save the result set by right clicking the mouse over the 
grid and choosing a name for the file. 
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Explain Plan

             For Oracle connections only, the user can browse the objects from the database using the tree 
representation from the left and can also choose to see the execution path for a specific select statement 
by clicking the explain button from the worksheet toolbar. 
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Placeholders

             Supports statements with placeholders in the worksheet. This way a user can insert something 
like a large object into the database. 
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Databases

             dbRadar works with the following databases: 
●     Oracle 
●     PostgreSql 
●     MySql 
●     DB2 

             Choose the connection you want from the driver combo box and fill in the text boxes with 
appropriate information. Ex for Oracle connections: 

Connections
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             There is support for multiple simultaneous database connections. Users can run multiple queries 
against any of the above queries without causing the user interface to hang. 
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Oracle Applications

●     Oracle Applications 

            System administrators and DBA for Oracle Applications 11.0. and 11.5 can monitor user activity 
and kill sessions more elegantly than ever before by choosing from the Oracle Applications menu the 
kill session window. 

Oracle Applications
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Debug

●     Debug 

             Users can debug any Oracle statemens and step in, out, and over the code. 

Debug
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System load

             From the Database menu the user can open a window with the system load from the server. This way 
monitoring the activity on the remote server is done more easily. The remote processes are also shown and by 
clicking on the lists header the user can sort those processes on every aspect of them. For example by clicking 
on %CPU we can see which process is consuming the most CPU. 

     The following information is provided: 

●     wait for input output 
●     idle 
●     user load 
●     system load 
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Database Objects

             dbRadar suports the following operations on database objects: create, edit, browse, drop, 
compile : (Currently only for Oracle ) 
●     New 
●     Edit 
●     Browse 
●     Drop 
●     Compile 

             Users can create, edit, drop, browse and compile tables, views, sequences, functions, procedures, 
packages, triggers and types. 

Objects
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             All the information available for a table is retrived from the database: storage, columns, keys, 
indexes, checks, privileges. 
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             You can easily see all the DDL for every database object. 
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F.A.Q

●     dbRadar for Linux doesn't load Oracle plugin: 

dbRadar for Linux doesn't load Oracle plugin:

            Check if the oracle plugin can load all of its dynamic libraries. For oracle 8i & 9i the client 
libraries are: 
●     > cd dbRadar-1.1.0-version/database/plugins/sqldrivers 
●     > ldd libqsqloci.so      Notice if you have a "not found" library. 
            Please check this path $ORACLE_HOME/lib to be included in /etc/ld.so.conf 
            In /etc/ld.so.conf you should have something like: /home/oracle/produc/8i/lib where the above is 
your $ORACLE_HOME/lib path. After setting this path please run ldconfig as root. 
            Please make sure that the user who is using dbRadar has acces to read into $ORACLE_HOME/
lib. 
            Please check with ldd $ORACLE_HOME/bin/sqlplus to see if there are any missing libraries. 

Home

Copyright © 2004 theKompany dbRadar version 1.1

file:///C|/Documents%20and%20Settings/Administrator/My%20Documents/make_cd/dbRadar/faq.html2/5/2004 4:51:20 AM

http://www.thekompany.com/

	Local Disk
	dbRadar Documentation
	dbRadar Documentation (Features)
	dbRadar Documentation (Connect Databases)
	dbRadar Documentation (Worksheet)
	dbRadar Documentation (Databases)
	dbRadar Documentation (Oracle Application)
	dbRadar Documentation (Debug)
	dbRadar Documentation (System Load)
	dbRadar Documentation (Databases)
	dbRadar Documentation (F.A.Q)


